RIP CheatSheet
Some of this taken from
CCIE Routing and Switching Certification Guide
Table of Contents
RIPv1
- distance vector protocol
- UDP port 520
- no support for VLSM or CIDR (no custom set subnets)
- metric is router hop count. max count is 15.
unreachable is 16
- updates broadcast
full update every 30 seconds, accept with serial link which is full update initially, than silent until update occurs.
- split horizon (don't advertise route back to interface it
was learned from) with poison reverse (advertise route with infinite
distance back on interface learned from)
- no authentication
- (Cisco) typical update timer = 30 seconds, (Cisco) typical
invalid timer is 180 seconds
- Regular updates can cause simultaneous update / jitter issues. RIP_JITTER variable added to time sent out (0-15%).
- uses variant of Bellman-Ford Algorithm
Timers
- Invalid timer - if update not received for 180 seconds - route goes to 16 (infinity)
- Flush timer - if upate not recieved for 240 seconds, route is flushed.
- Holddown timer - 180 seconds to deal with flapping
Timer Comparison
| Hello | (RIP-Invalid) (OSPF-Suspicious) | Dead (RIP-Flush) | Holddown |
RIP | 30 | 180 (6x) | 240 (8x) | 180 |
OSPF | 10 BMA 30 NBMA | 90 (3x) | 120 (4x) | 5 second delay + 10 seconds Hold |
EIGRP | 5 60 WAN < 1.544Mbps | | | 15 (3x) |
STP | 2 | | | 20 blocking 15 listening 15 learning forwarding |
Cisco Config lines
hostname darouter
!
interface Ethernet0
ip addr 192.168.0.1 255.255.255.0
!
interface Serial0
ip address 172.16.1.1 255.255.255.0
!
router rip
network
192.168.0.1
network
172.16.1.1
show ip route
show ip rip database
RIPv2
- distance vector protocol
- UDP port 520
- CIDR and VLSM supported. subnet mask included in
route entry
- metric is router hop count. max count is 15.
unreachable is 16
- updates via multicast
every 30 seconds (to 224.0.0.9).
- supports authentication (PAP and CHAP)
- split horizon with poison reverse
- remember no auto-summary - otherwise will summarize on classful boundaries
- able to do load balancing - default 4 equal cost paths - can force to 6 with maximum-paths <# of paths>
- supports manual route/supernet summarizing
Cisco Config lines
hostname darouter
!
key chain dakeychain
key 1
key-string dakeystring
!
interface Ethernet0
ip address 192.168.0.1 255.255.255.0
ip rip authentication key-chain dakeychain
!
interface Serial0
ip address 192.168.1.1 255.255.255.252
!
router rip
version 2
network
192.168.0.0 (what networks connected to me that
I'm going to advertise)
show ip route
show ip protocols
debug ip rip