Cisco WiFi Notes

Notes from Deploying and Troubleshooting Cisco Wireless LAN Controllers: A Practical Guide to working with the Cisco Unified Wireless Solution

Table of Contents

Switchport cfg that connects to WLC

interface GigabitEthernet1/0/1
 description Trunk Port to Cisco WLC
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 2-4,7
 switchport mode trunk
 no shutdown

Switchport cfg of switch conn to AP

interface VLAN4
  description THe AP VLAN
  ip adress 10.6.6.1 255.255.255.0

Switchport cfg of port to AP

interface GigabitEthernet1/0/22
 switchport access vlan 4
 switchport mode access 
 no shutdown
 

L3 discovery mechanism

  1. L3 discovery req to all switch ip addrs found in AP cfg
  2. L3 discovery req to all ip addrs in DHCP Vendor options
  3. collect controller info via DNS
  4. L3 discovery req to ip addrs learned by sniffing neighbor broadcast address
  5. L3 discovery req to subnet broadcast

Lightweight access points (LAP) zero-tech registration steps

AP Discovery and AP Join

CAPWAP environment - LAP discovers controller using CAPWAP discovvery.

Debugging

'All CAPWAP ctrl packets except discovery request and response are encrypted, so an (packet) trace does not give details.... For debugging, disabling encrypting is supported....
from Deploying and Troubleshooting Cisco Wireless LAN Controllers: A Practical Guide to working with the Cisco Unified Wireless Solution

Enable ap connectivity and debugging

set global password on WLC
config ap ssh enable usboswap101 (from WLC)
debug client mac_address (on AP - lots of info...log it)
debug dot11 ?
debug dot11 aaa authticator all
Online wireless debug analyzer for debug client output

Configuring DHCP to connect Cisco AP to WLC

got some of this from the YouTube video Cisco CCNA Wireless - COnfiguring a Wireless LAN Controller
ip dhcp excluded-address 10.6.6.1 10.6.6.10
ip dhcp excluded-address 10.6.6.254
ip dhcp pool wifi1
  network 10.6.6.0 255.255.255.0
  domain-name dalab.com
  dns-server 10.6.6.1
  default-router 10.6.6.254
  option 43 hex f108.0a04.0102.0a04.0103 (10.4.1.2 and 10.4.1.30)
  option 60 ascii "Cisco AP c3500"
interface GigabitEthernet0/10
  description connection to 3500e AP
  switchport access vlan 6
  switchport mode access
interface vlan 60
  description AP 3500 VLAN 6
  ip address 10.6.6.1 255.255.255.0

(don't forget to extend vlan over trunk back towards WLC)
  
show ip dhcp binding
quoted from Cisco DHCP OPTION 43 for Lightweight Cisco Aironet Access Points Configuration Example
When DHCP servers are programmed to offer WLAN Controller IP addresses as Option 43 for Cisco 1000 Series APs the sub-option TLV block is defined in this way:
When DHCP servers are programmed to offer WLAN Controller IP addresses as Option 43 for other Cisco Aironet LAPs, the sub-option TLV block is defined in this way:

RFC 2132 defines two DHCP Options that are relevant to vendor specific options. They are Option 60 and Option 43. DHCP Option 60 is the Vendor Class Identifier (VCI). The VCI is a text string that uniquely identifies a type of vendor device. This table lists the VCIs used by Cisco APs:

Access PointVendor Class Identifier (VCI)
Cisco Aironet 1000 SeriesAirespace.AP1200
Cisco Aironet 1040 SeriesCisco AP c1040
Cisco Aironet 1100 SeriesCisco AP c1100
Cisco Aironet 1130 SeriesCisco AP c1130
Cisco Aironet 1140 SeriesCisco AP c1140
Cisco Aironet 1200 SeriesCisco AP c1200
Cisco Aironet 1230 SeriesCisco AP c1200
Cisco Aironet 1240 SeriesCisco AP c1240
Cisco Aironet 1250 SeriesCisco AP c1250
Cisco Aironet 1260 SeriesCisco AP c1260
Cisco Aironet 1300 SeriesCisco AP c1310
Cisco Aironet 1500 SeriesCisco AP c15001 Cisco AP.OAP15002 Cisco AP.LAP15053 Cisco AP.LAP15104 Airespace.AP12005
Cisco Aironet 1520 SeriesCisco AP c1520
Cisco Aironet 1550 SeriesCisco AP c1550
Cisco 3201 Lightweight Access PointCisco Bridge/AP/WGB c3201
Cisco 521 Wireless Express Access PointCisco AP c520
AP801 (embedded in 86x/88x Series ISRsCisco AP801
Cisco Aironet 3500 SeriesCisco AP c3500
Cisco Aironet 3600 SeriesCisco AP c3600
AP802 (embedded in 88x Series ISRsCisco AP802
Cisco Aironet 2700 SeriesCisco AP c27006
Cisco Aironet 3700 SeriesCisco AP c37007
Cisco Aironet 700 SeriesCisco AP c7006
Cisco Aironet 1530 SeriesCisco AP c15306

1Any 1500 Series AP that runs 4.1 software

21500 OAP AP that runs 4.0 software

31505 Model AP that runs 4.0 software

41510 Model AP that runs 4.0 software

5Any 1500 Series AP that runs 3.2 software

6Any 2700/700/1530 Series AP that runs 7.6.120.0 or later software

7Any 3700 Series AP that runs 7.6 or later software

Configuring WLC to support new AP and dhcp settings